9810 C# Programming Manual: D:/9810/C# Directory Reference

9810 C# Programming Manual
C# Directory Reference

Files

file JY9810AITask.cs
Generated by doxygen 1.9.1


9810 C# Programming Manual: D:/9810/C#/JY9810AITask.cs File Reference

Classes | Namespaces | Enumerations
JY9810AITask.cs File Reference

Classes

class | JY9810.JY9810AITask
JY9810 AI Task Class More...
class | JY9810.AIChannel
AI Channel Parament Class More...
class | JY9810.AISampleClock
Sample clock configuration class More...
class | JY9810.AIExternalSampleClock
External Sample Clock Configuration Class More...
class | JY9810.AITrigger
AI Trigger class More...
class | JY9810.AIDigitalTrigger
AI Digital Trigger More...
class | JY9810.AIAnalogTrigger
AI analog trigger . More...
class | JY9810.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | JY9810.AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | JY9810.AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | JY9810.AIRecord
AI Record class More...
class | JY9810.AIRecordAdvanced
AI Record Advanced class More...
class | JY9810.AISync
Configure sync signal More...
class | JY9810.AISignalExport
AI Signal Export Class More...

Namespaces

namespace JY9810

Enumerations

enum class | JY9810.AICoupling { JY9810.DC = JY9810Import.JY9810_AI_DC_Couple , JY9810.AC = JY9810Import.JY9810_AI_AC_Couple }
AI Coupling enum More...
enum class | JY9810.AIImpedance { JY9810.Impedance50Ohm = JY9810Import.JY9810_AI_OHM_50 , JY9810.ImpedanceHigh = JY9810Import.JY9810_AI_OHM_1M }
AI Impedance More...
enum class | JY9810.AITriggerType { JY9810.Immediate = JY9810Import.JY9810_TriggerType_Immediately , JY9810.Digital = JY9810Import.JY9810_TriggerType_Digital , JY9810.Analog = JY9810Import.JY9810_TriggerType_Analog , JY9810.Soft = JY9810Import.JY9810_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | JY9810.AIDigitalTriggerEdge { JY9810.Rising = 0 , JY9810.Falling = 1 }
AI Digital Trigger Edge More...
enum class | JY9810.AIMode { JY9810.Finite = JY9810Import.JY9810_Finite , JY9810.Continuous = JY9810Import.JY9810_Continuous , JY9810.Record = 0x3 }
AIMode More...
enum class | JY9810.AISampleClockSource { JY9810.Internal = 0 , JY9810.External = 1 }
AIClockSource Type More...
enum class | JY9810.ClockTerminal { JY9810.CLK_IN }
External Sample Clock Terminal More...
enum class | JY9810.AITriggerMode { JY9810.Start , JY9810.Reference }
AI Trigger Mode More...
enum class JY9810.AIDigitalTriggerSource {
JY9810.PXI_Trig0 = JY9810Import.JY9810_DigitalTriggerSource_PXI_0 , JY9810.PXI_Trig1 = JY9810Import.JY9810_DigitalTriggerSource_PXI_1 , JY9810.PXI_Trig2 = JY9810Import.JY9810_DigitalTriggerSource_PXI_2 , JY9810.PXI_Trig3 = JY9810Import.JY9810_DigitalTriggerSource_PXI_3 ,
JY9810.PXI_Trig4 = JY9810Import.JY9810_DigitalTriggerSource_PXI_4 , JY9810.PXI_Trig5 = JY9810Import.JY9810_DigitalTriggerSource_PXI_5 , JY9810.PXI_Trig6 = JY9810Import.JY9810_DigitalTriggerSource_PXI_6 , JY9810.PXI_Trig7 = JY9810Import.JY9810_DigitalTriggerSource_PXI_7 ,
JY9810.PFI_0 = JY9810Import.JY9810_DigitalTriggerSource_TRIG_IN , JY9810.PXIe_DStarB = JY9810Import.JY9810_DigitalTriggerSource_PXIe_DStarB , JY9810.PXIe_DStarC = JY9810Import.JY9810_DigitalTriggerSource_PXIe_DStarC
}
AI Digital Trigger Source More...
enum class | JY9810.AIAnalogTriggerSource { JY9810.Channel_0 , JY9810.Channel_1 , JY9810.Channel_2 , JY9810.Channel_3 }
AI Analog Trigger Source More...
enum class | JY9810.AIAnalogTriggerEdge { JY9810.Rising , JY9810.Falling }
AI Analog Trigger Edge More...
enum class | JY9810.AIAnalogWindowCondition { JY9810.Entering , JY9810.Leaving }
AI Analog Window Trigger Condition More...
enum class | JY9810.AIAnalogTriggerComparator { JY9810.Edge , JY9810.Hysteresis , JY9810.Window }
AI Analog Trigger Comparator More...
enum class JY9810.AISignalExportSource {
JY9810.PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , JY9810.PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , JY9810.PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 , JY9810.PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 ,
JY9810.PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , JY9810.PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , JY9810.PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 , JY9810.PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 ,
JY9810.StartTrig = JY9810Import.JY9810_StartTrigger , JY9810.ReferenceTrig = JY9810Import.JY9810_RefTrigger , JY9810.SyncTriggerOut = JY9810Import.SyncSignal_IN , JY9810.SyncValidOut = JY9810Import.JY9810_PLL_SYNC_OUT ,
JY9810.AIClkOut = 20 , JY9810.PLLClkOut = 19 , JY9810.AIClkDivider = 7 , JY9810.SyncValidDelayOut = 25
}
AI Signal Export Source More...
enum class | JY9810.FileFormat { JY9810.Bin }
Streaming file format More...
enum class | JY9810.RecordMode { JY9810.Finite , JY9810.Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | JY9810.SyncTopology { JY9810.Independent , JY9810.Master , JY9810.Slave }
Synchronization board configuration More...
enum class JY9810.SyncTriggerRouting {
JY9810.NONE = -1 , JY9810.PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , JY9810.PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , JY9810.PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 ,
JY9810.PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 , JY9810.PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , JY9810.PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , JY9810.PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 ,
JY9810.PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 , JY9810.PFI_0 = JY9810Import.JY9810_TriggerOut_TRG_OUT
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class JY9810.SyncPulseRouting {
JY9810.NONE = -1 , JY9810.PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , JY9810.PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , JY9810.PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 ,
JY9810.PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 , JY9810.PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , JY9810.PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , JY9810.PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 ,
JY9810.PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 , JY9810.PFI_0 = JY9810Import.JY9810_TriggerOut_TRG_OUT
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...
enum class JY9810.SignalExportDestination {
JY9810.PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , JY9810.PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , JY9810.PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 , JY9810.PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 ,
JY9810.PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , JY9810.PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , JY9810.PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 , JY9810.PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 ,
JY9810.PFI_0 = JY9810Import.JY9810_TriggerOut_TRG_OUT
}
Output DestinationTerminal More...


9810 C# Programming Manual: JY9810.JY9810AITask Class Reference

  • JY9810
  • JY9810AITask
Public Member Functions | Public Attributes | Properties | List of all members
JY9810.JY9810AITask Class Reference

JY9810 AI Task Class More...

Public Member Functions

JY9810AITask (int slotNumber)
Constructor. More...
JY9810AITask (string boardName)
Constructor. More...
void | AddChannel (int channelID, double rangeLow=-10, double rangeHigh=10, AICoupling coupling=AICoupling.DC, AIImpedance impedance=AIImpedance.Impedance50Ohm)
Add one channel. More...
void | AddChannel (int[] channelIDs, double rangeLow=-5, double rangeHigh=5, AICoupling coupling=AICoupling.DC, AIImpedance impedance=AIImpedance.Impedance50Ohm)
Add a group of channels. More...
void | AddChannel (int[] channelIDs, double[] rangeLow, double[] rangeHigh, AICoupling[] coupling, AIImpedance[] impedance)
Add a group of channels, each channel range can be set differently More...
void | RemoveChannel (int channelID)
Delete the channel with the specified channel number. More...
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer. More...
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (ref double[,] buf, int timeout)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadData (ref double[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel raw data by columns and store it in a data buffer. More...
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data More...
void | ReadRawData (ref short[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data More...
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadRawData (ref short[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete More...
void | Start ()
Start AITask More...
void | SendSoftwareTrigger ()
Generate a software trigger signal More...
void | Stop ()
Stop AI Task More...

Public Attributes

double _adjustedSampleRate

Properties

JY9810Device | Device [get]
Device Handle More...
List< AIChannel > | Channels [get]
List of AI channels More...
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record More...
double | SampleRate [get, set]
Sample rate per channel. More...
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration More...
UInt64 | SamplesToAcquire [get, set]
Number of samples to be read per channel. More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value. More...
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration More...
AISync | Sync [get]
Multi card synchronous configuration More...
bool | DisableCalibration [get, set]
Disalble calibration More...
AITrigger | Trigger [get]
AI Trigger Configuration More...
AIRecord | Record = new AIRecord() [get]
Data streaming Configuration More...

Detailed Description

JY9810 AI Task Class

Constructor & Destructor Documentation

◆ JY9810AITask() [1/2]

JY9810.JY9810AITask.JY9810AITask ( int slotNumber )

Constructor.

Used to create an AI task object.

Parameters
slotNumber Card slot number.

◆ JY9810AITask() [2/2]

JY9810.JY9810AITask.JY9810AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY9810.JY9810AITask.AddChannel | ( | int | channelID,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AICoupling | coupling = AICoupling.DC,
 |  | AIImpedance | impedance = AIImpedance.Impedance50Ohm
 | ) |  |

Add one channel.

Parameters
channelID | channel's physical number ，chnId=-1, add all channels
rangeLow | lower range limit for the channel，-10V，5V，-1V，-0.5V
rangeHigh | higher range limit for the channel，10V，5V，1V，0.5V
coupling | coupling
impedance | impedance
Returns

◆ AddChannel() [2/3]

void JY9810.JY9810AITask.AddChannel | ( | int[] | channelIDs,
 |  | double | rangeLow = -5,
 |  | double | rangeHigh = 5,
 |  | AICoupling | coupling = AICoupling.DC,
 |  | AIImpedance | impedance = AIImpedance.Impedance50Ohm
 | ) |  |

Add a group of channels.

Parameters
channelIDs | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V，5V，-1V，-0.5V
rangeHigh | higher range limit for the channel，10V，5V，1V，0.5V
coupling | coupling
impedance | impedance
Returns

◆ AddChannel() [3/3]

void JY9810.JY9810AITask.AddChannel | ( | int[] | channelIDs,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AICoupling[] | coupling,
 |  | AIImpedance[] | impedance
 | ) |  |

Add a group of channels, each channel range can be set differently

Parameters
channelIDs | a group of channel physical numbers,different mode 0-15
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V
rangeHigh | higher range limit for the channel,10V,5V,2V，1V
coupling | coupling
impedance | impedance

◆ GetRecordPreviewData() [1/4]

void JY9810.JY9810AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY9810.JY9810AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms
Returns

◆ GetRecordPreviewData() [3/4]

void JY9810.JY9810AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY9810.JY9810AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY9810.JY9810AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone
 | ) |  |

Get the streaming status

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over
Returns

◆ ReadData() [1/5]

void JY9810.JY9810AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/5]

void JY9810.JY9810AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [3/5]

void JY9810.JY9810AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
timeout timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [4/5]

void JY9810.JY9810AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadData() [5/5]

void JY9810.JY9810AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [1/5]

void JY9810.JY9810AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/5]

void JY9810.JY9810AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [3/5]

void JY9810.JY9810AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [4/5]

void JY9810.JY9810AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [5/5]

void JY9810.JY9810AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ RemoveChannel()

void JY9810.JY9810AITask.RemoveChannel ( int channelID )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
channelID Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY9810.JY9810AITask.SendSoftwareTrigger ( )

Generate a software trigger signal

Returns

◆ Start()

void JY9810.JY9810AITask.Start ( )

Start AITask

◆ Stop()

void JY9810.JY9810AITask.Stop ( )

Stop AI Task

◆ WaitUntilDone()

bool JY9810.JY9810AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate

Member Data Documentation

◆ _adjustedSampleRate

double JY9810.JY9810AITask._adjustedSampleRate

Property Documentation

◆ AvailableSamples

ulong JY9810.JY9810AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer

◆ BufLenInSamples

int JY9810.JY9810AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JY9810.JY9810AITask.Channels
get

List of AI channels

◆ Device

JY9810Device JY9810.JY9810AITask.Device
get

Device Handle

◆ DisableCalibration

bool JY9810.JY9810AITask.DisableCalibration
getset

Disalble calibration

◆ Mode

AIMode JY9810.JY9810AITask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record

◆ Record

AIRecord JY9810.JY9810AITask.Record = new AIRecord()
get

Data streaming Configuration

◆ SampleClock

AISampleClock JY9810.JY9810AITask.SampleClock
getset

AI Sample Clock Configuration

◆ SampleRate

double JY9810.JY9810AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 125M for ecah channel. The defalut sample rate = 125M You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

UInt64 JY9810.JY9810AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY9810.JY9810AITask.SignalExport
getset

Export AI Signal Configuration

◆ Sync

AISync JY9810.JY9810AITask.Sync
get

Multi card synchronous configuration

◆ TransferedSamples

ulong JY9810.JY9810AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY9810.JY9810AITask.Trigger
get

AI Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIChannel Class Reference

  • AIChannel
Properties | List of all members
JY9810.AIChannel Class Reference

AI Channel Parament Class More...

Properties

int | ChannelID [get]
AI channel ID. More...
double | RangeLow [get, set]
Low range limit an AI channel -10V,-5V, -1V，-0.5V More...
double | RangeHigh [get, set]
High range limit an AI channel 10V,5V, 1V，0.5V More...
AICoupling | Coupling [get, set]
AI Coupling More...
AIImpedance | Impedance [get, set]
AI Impedance More...

Detailed Description

AI Channel Parament Class

Property Documentation

◆ ChannelID

int JY9810.AIChannel.ChannelID
get

AI channel ID.

◆ Coupling

AICoupling JY9810.AIChannel.Coupling
getset

AI Coupling

◆ Impedance

AIImpedance JY9810.AIChannel.Impedance
getset

AI Impedance

◆ RangeHigh

double JY9810.AIChannel.RangeHigh
getset

High range limit an AI channel 10V,5V, 1V，0.5V

◆ RangeLow

double JY9810.AIChannel.RangeLow
getset

Low range limit an AI channel -10V,-5V, -1V，-0.5V

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY9810.AISampleClock Class Reference

Sample clock configuration class More...

Properties

AISampleClockSource | Source [get, set]
Clock Source. More...
AIExternalSampleClock | External [get, set]
External SampleClock， Valid when Source is AISampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

AIExternalSampleClock JY9810.AISampleClock.External
getset

External SampleClock， Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY9810.AISampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JY9810.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY9810.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY9810.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY9810.AITrigger Class Reference

AI Trigger class More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft. More...
AITriggerMode | Mode [get, set]
AI Trigger Mode. More...
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration. More...
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger. More...
int | ReTriggerCount [get, set]
Number of repeat triggers. More...
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY9810AITask.SamplesToAcquire. More...

Detailed Description

AI Trigger class

Property Documentation

◆ Analog

AIAnalogTrigger JY9810.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JY9810.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY9810.AITrigger.Mode
getset

AI Trigger Mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JY9810.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY9810AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY9810.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY9810.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft.

The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY9810.AIDigitalTrigger Class Reference

AI Digital Trigger More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source More...
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling More...

Detailed Description

AI Digital Trigger

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY9810.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling

◆ Source

AIDigitalTriggerSource JY9810.AIDigitalTrigger.Source
getset

AI Digital Trigger Source

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY9810.AIAnalogTrigger Class Reference

AI analog trigger . More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source More...
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator More...
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator More...
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr More...
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr More...

Detailed Description

AI analog trigger .

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY9810.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator

◆ Edge

AIAnalogEdgeComparator JY9810.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator

◆ Hysteresis

AIAnalogHysteresisComparator JY9810.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr

◆ Source

AIAnalogTriggerSource JY9810.AIAnalogTrigger.Source
getset

Analog Trigger source

◆ Window

AIAnalogWindowComparator JY9810.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY9810.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Hysteresis Comparatorr

Member Data Documentation

◆ HighThreshold

double JY9810.AIAnalogHysteresisComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY9810.AIAnalogHysteresisComparator.LowThreshold

Low Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9810.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY9810.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition More...

Detailed Description

AI Analog Window Comparatorr

Member Data Documentation

◆ HighThreshold

double JY9810.AIAnalogWindowComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY9810.AIAnalogWindowComparator.LowThreshold

Low Threshold

Property Documentation

◆ Condition

AIAnalogWindowCondition JY9810.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY9810.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator More...

Public Attributes

double Threshold
Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Edge Comparator

Member Data Documentation

◆ Threshold

double JY9810.AIAnalogEdgeComparator.Threshold

Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9810.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY9810.AIRecord Class Reference

AI Record class More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename More...
FileFormat | FileFormat [get]
Streaming file format More...
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite More...
double | Length [get, set]
User specified stream length in second. More...
AIRecordAdvanced | Advanced [get, set]
The adcanced property for record More...

Detailed Description

AI Record class

Property Documentation

◆ Advanced

AIRecordAdvanced JY9810.AIRecord.Advanced
getset

The adcanced property for record

◆ FileFormat

FileFormat JY9810.AIRecord.FileFormat
get

Streaming file format

◆ FilePath

string JY9810.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename

◆ Length

double JY9810.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode.Default 1 s

◆ Mode

RecordMode JY9810.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AIRecordAdvanced Class Reference

  • AIRecordAdvanced
Properties | List of all members
JY9810.AIRecordAdvanced Class Reference

AI Record Advanced class More...

Properties

int | PreviewBufferSize [get, set]
The size of the circular buffer to save preview data(Bytes) More...
int | SamplesToPreviewBuffer [get, set]
The length of data per write to the preview buffer(Samples) More...
int | BlockSize [get, set]
The size of each record data buffer(Bytes) More...
int | BlockCount [get, set]
The count of record buffer More...

Detailed Description

AI Record Advanced class

Property Documentation

◆ BlockCount

int JY9810.AIRecordAdvanced.BlockCount
getset

The count of record buffer

◆ BlockSize

int JY9810.AIRecordAdvanced.BlockSize
getset

The size of each record data buffer(Bytes)

◆ PreviewBufferSize

int JY9810.AIRecordAdvanced.PreviewBufferSize
getset

The size of the circular buffer to save preview data(Bytes)

◆ SamplesToPreviewBuffer

int JY9810.AIRecordAdvanced.SamplesToPreviewBuffer
getset

The length of data per write to the preview buffer(Samples)

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AISync Class Reference

  • AISync
Public Member Functions | Properties | List of all members
JY9810.AISync Class Reference

Configure sync signal More...

Public Member Functions

void Commit ()
commit sync config More...

Properties

SyncTopology | Topology [get, set]
Configure sync More...
int | SyncDelaySamplesNum [get]
主从同步时导致固定的trigger延迟，因为主从同步时，主卡会将接收到的触发信号进行延迟到下一个低速同步脉冲，用于同步AI的起始采样点 More...
SyncTriggerRouting | TriggerRouting [get, set]
trigger signal Routing, default routing PXITrig0 More...
SyncPulseRouting | PulseRouting [get, set]
Sync Pulse signal Routing, default routing PXITrig1 More...

Detailed Description

Configure sync signal

Member Function Documentation

◆ Commit()

void JY9810.AISync.Commit ( )

commit sync config

Property Documentation

◆ PulseRouting

SyncPulseRouting JY9810.AISync.PulseRouting
getset

Sync Pulse signal Routing, default routing PXITrig1

◆ SyncDelaySamplesNum

int JY9810.AISync.SyncDelaySamplesNum
get

主从同步时导致固定的trigger延迟，因为主从同步时，主卡会将接收到的触发信号进行延迟到下一个低速同步脉冲，用于同步AI的起始采样点

◆ Topology

SyncTopology JY9810.AISync.Topology
getset

Configure sync

◆ TriggerRouting

SyncTriggerRouting JY9810.AISync.TriggerRouting
getset

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: JY9810.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9810.AISignalExport Class Reference

AI Signal Export Class More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

AI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY9810.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY9810.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY9810.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY9810.AISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/9810/C#/JY9810AITask.cs


9810 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9810 |
C JY9810AITask | JY9810 AI Task Class
C AIChannel | AI Channel Parament Class
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI analog trigger
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIRecord | AI Record class
C AIRecordAdvanced | AI Record Advanced class
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class


9810 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9810.AIAnalogEdgeComparator Member List

This is the complete list of members for JY9810.AIAnalogEdgeComparator, including all inherited members.

Slope | JY9810.AIAnalogEdgeComparator
Threshold | JY9810.AIAnalogEdgeComparator


9810 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9810.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9810.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9810.AIAnalogHysteresisComparator
LowThreshold | JY9810.AIAnalogHysteresisComparator
Slope | JY9810.AIAnalogHysteresisComparator


9810 C# Programming Manual: Member List

  • AIAnalogTrigger
JY9810.AIAnalogTrigger Member List

This is the complete list of members for JY9810.AIAnalogTrigger, including all inherited members.

Comparator | JY9810.AIAnalogTrigger
Edge | JY9810.AIAnalogTrigger
Hysteresis | JY9810.AIAnalogTrigger
Source | JY9810.AIAnalogTrigger
Window | JY9810.AIAnalogTrigger


9810 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY9810.AIAnalogWindowComparator Member List

This is the complete list of members for JY9810.AIAnalogWindowComparator, including all inherited members.

Condition | JY9810.AIAnalogWindowComparator
HighThreshold | JY9810.AIAnalogWindowComparator
LowThreshold | JY9810.AIAnalogWindowComparator


9810 C# Programming Manual: Member List

  • AIChannel
JY9810.AIChannel Member List

This is the complete list of members for JY9810.AIChannel, including all inherited members.

ChannelID | JY9810.AIChannel
Coupling | JY9810.AIChannel
Impedance | JY9810.AIChannel
RangeHigh | JY9810.AIChannel
RangeLow | JY9810.AIChannel


9810 C# Programming Manual: Member List

  • AIDigitalTrigger
JY9810.AIDigitalTrigger Member List

This is the complete list of members for JY9810.AIDigitalTrigger, including all inherited members.

Edge | JY9810.AIDigitalTrigger
Source | JY9810.AIDigitalTrigger


9810 C# Programming Manual: Member List

  • AIExternalSampleClock
JY9810.AIExternalSampleClock Member List

This is the complete list of members for JY9810.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY9810.AIExternalSampleClock
Terminal | JY9810.AIExternalSampleClock


9810 C# Programming Manual: Member List

  • AIRecord
JY9810.AIRecord Member List

This is the complete list of members for JY9810.AIRecord, including all inherited members.

Advanced | JY9810.AIRecord
FileFormat | JY9810.AIRecord
FilePath | JY9810.AIRecord
Length | JY9810.AIRecord
Mode | JY9810.AIRecord


9810 C# Programming Manual: Member List

  • AIRecordAdvanced
JY9810.AIRecordAdvanced Member List

This is the complete list of members for JY9810.AIRecordAdvanced, including all inherited members.

BlockCount | JY9810.AIRecordAdvanced
BlockSize | JY9810.AIRecordAdvanced
PreviewBufferSize | JY9810.AIRecordAdvanced
SamplesToPreviewBuffer | JY9810.AIRecordAdvanced


9810 C# Programming Manual: Member List

  • AISampleClock
JY9810.AISampleClock Member List

This is the complete list of members for JY9810.AISampleClock, including all inherited members.

External | JY9810.AISampleClock
Source | JY9810.AISampleClock


9810 C# Programming Manual: Member List

  • AISignalExport
JY9810.AISignalExport Member List

This is the complete list of members for JY9810.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9810.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY9810.AISignalExport
Clear(SignalExportDestination destination) | JY9810.AISignalExport
ClearAll() | JY9810.AISignalExport


9810 C# Programming Manual: Member List

  • AISync
JY9810.AISync Member List

This is the complete list of members for JY9810.AISync, including all inherited members.

Commit() | JY9810.AISync
PulseRouting | JY9810.AISync
SyncDelaySamplesNum | JY9810.AISync
Topology | JY9810.AISync
TriggerRouting | JY9810.AISync


9810 C# Programming Manual: Member List

  • AITrigger
JY9810.AITrigger Member List

This is the complete list of members for JY9810.AITrigger, including all inherited members.

Analog | JY9810.AITrigger
Digital | JY9810.AITrigger
Mode | JY9810.AITrigger
PreTriggerSamples | JY9810.AITrigger
ReTriggerCount | JY9810.AITrigger
Type | JY9810.AITrigger


9810 C# Programming Manual: Member List

  • JY9810AITask
JY9810.JY9810AITask Member List

This is the complete list of members for JY9810.JY9810AITask, including all inherited members.

_adjustedSampleRate | JY9810.JY9810AITask
AddChannel(int channelID, double rangeLow=-10, double rangeHigh=10, AICoupling coupling=AICoupling.DC, AIImpedance impedance=AIImpedance.Impedance50Ohm) | JY9810.JY9810AITask
AddChannel(int[] channelIDs, double rangeLow=-5, double rangeHigh=5, AICoupling coupling=AICoupling.DC, AIImpedance impedance=AIImpedance.Impedance50Ohm) | JY9810.JY9810AITask
AddChannel(int[] channelIDs, double[] rangeLow, double[] rangeHigh, AICoupling[] coupling, AIImpedance[] impedance) | JY9810.JY9810AITask
AvailableSamples | JY9810.JY9810AITask
BufLenInSamples | JY9810.JY9810AITask
Channels | JY9810.JY9810AITask
Device | JY9810.JY9810AITask
DisableCalibration | JY9810.JY9810AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY9810.JY9810AITask
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY9810.JY9810AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY9810.JY9810AITask
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY9810.JY9810AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY9810.JY9810AITask
JY9810AITask(int slotNumber) | JY9810.JY9810AITask
JY9810AITask(string boardName) | JY9810.JY9810AITask
Mode | JY9810.JY9810AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY9810.JY9810AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY9810.JY9810AITask
ReadData(ref double[,] buf, int timeout) | JY9810.JY9810AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout=10000) | JY9810.JY9810AITask
ReadData(ref double[] buf, int timeout=10000) | JY9810.JY9810AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY9810.JY9810AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout=10000) | JY9810.JY9810AITask
ReadRawData(ref short[,] buf, int timeout=10000) | JY9810.JY9810AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout=10000) | JY9810.JY9810AITask
ReadRawData(ref short[] buf, int timeout=10000) | JY9810.JY9810AITask
Record | JY9810.JY9810AITask
RemoveChannel(int channelID) | JY9810.JY9810AITask
SampleClock | JY9810.JY9810AITask
SampleRate | JY9810.JY9810AITask
SamplesToAcquire | JY9810.JY9810AITask
SendSoftwareTrigger() | JY9810.JY9810AITask
SignalExport | JY9810.JY9810AITask
Start() | JY9810.JY9810AITask
Stop() | JY9810.JY9810AITask
Sync | JY9810.JY9810AITask
TransferedSamples | JY9810.JY9810AITask
Trigger | JY9810.JY9810AITask
WaitUntilDone(int timeout=-1) | JY9810.JY9810AITask


9810 C# Programming Manual: Class Index

Class Index
A | J
A
AIAnalogEdgeComparator (JY9810)
AIAnalogHysteresisComparator (JY9810)
AIAnalogTrigger (JY9810)
AIAnalogWindowComparator (JY9810)
AIChannel (JY9810)
AIDigitalTrigger (JY9810)
AIExternalSampleClock (JY9810)
AIRecord (JY9810)
AIRecordAdvanced (JY9810)
AISampleClock (JY9810)
AISignalExport (JY9810)
AISync (JY9810)
AITrigger (JY9810)
J
JY9810AITask (JY9810)


9810 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 9810


9810 C# Programming Manual: D:/9810 Directory Reference

  • D:
  • 9810
9810 Directory Reference

Directories

directory C#


9810 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 9810
▼ C#
JY9810AITask.cs


9810 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- _ -

  • _adjustedSampleRate : JY9810.JY9810AITask

- a -

  • Add() : JY9810.AISignalExport
  • AddChannel() : JY9810.JY9810AITask
  • Advanced : JY9810.AIRecord
  • Analog : JY9810.AITrigger
  • AvailableSamples : JY9810.JY9810AITask

- b -

  • BlockCount : JY9810.AIRecordAdvanced
  • BlockSize : JY9810.AIRecordAdvanced
  • BufLenInSamples : JY9810.JY9810AITask

- c -

  • ChannelID : JY9810.AIChannel
  • Channels : JY9810.JY9810AITask
  • Clear() : JY9810.AISignalExport
  • ClearAll() : JY9810.AISignalExport
  • Commit() : JY9810.AISync
  • Comparator : JY9810.AIAnalogTrigger
  • Condition : JY9810.AIAnalogWindowComparator
  • Coupling : JY9810.AIChannel

- d -

  • Device : JY9810.JY9810AITask
  • Digital : JY9810.AITrigger
  • DisableCalibration : JY9810.JY9810AITask

- e -

  • Edge : JY9810.AIAnalogTrigger , JY9810.AIDigitalTrigger
  • ExpectedRate : JY9810.AIExternalSampleClock
  • External : JY9810.AISampleClock

- f -

  • FileFormat : JY9810.AIRecord
  • FilePath : JY9810.AIRecord

- g -

  • GetRecordPreviewData() : JY9810.JY9810AITask
  • GetRecordStatus() : JY9810.JY9810AITask

- h -

  • HighThreshold : JY9810.AIAnalogHysteresisComparator , JY9810.AIAnalogWindowComparator
  • Hysteresis : JY9810.AIAnalogTrigger

- i -

  • Impedance : JY9810.AIChannel

- j -

  • JY9810AITask() : JY9810.JY9810AITask

- l -

  • Length : JY9810.AIRecord
  • LowThreshold : JY9810.AIAnalogHysteresisComparator , JY9810.AIAnalogWindowComparator

- m -

  • Mode : JY9810.AIRecord , JY9810.AITrigger , JY9810.JY9810AITask

- p -

  • PreTriggerSamples : JY9810.AITrigger
  • PreviewBufferSize : JY9810.AIRecordAdvanced
  • PulseRouting : JY9810.AISync

- r -

  • RangeHigh : JY9810.AIChannel
  • RangeLow : JY9810.AIChannel
  • ReadData() : JY9810.JY9810AITask
  • ReadRawData() : JY9810.JY9810AITask
  • Record : JY9810.JY9810AITask
  • RemoveChannel() : JY9810.JY9810AITask
  • ReTriggerCount : JY9810.AITrigger

- s -

  • SampleClock : JY9810.JY9810AITask
  • SampleRate : JY9810.JY9810AITask
  • SamplesToAcquire : JY9810.JY9810AITask
  • SamplesToPreviewBuffer : JY9810.AIRecordAdvanced
  • SendSoftwareTrigger() : JY9810.JY9810AITask
  • SignalExport : JY9810.JY9810AITask
  • Slope : JY9810.AIAnalogEdgeComparator , JY9810.AIAnalogHysteresisComparator
  • Source : JY9810.AIAnalogTrigger , JY9810.AIDigitalTrigger , JY9810.AISampleClock
  • Start() : JY9810.JY9810AITask
  • Stop() : JY9810.JY9810AITask
  • Sync : JY9810.JY9810AITask
  • SyncDelaySamplesNum : JY9810.AISync

- t -

  • Terminal : JY9810.AIExternalSampleClock
  • Threshold : JY9810.AIAnalogEdgeComparator
  • Topology : JY9810.AISync
  • TransferedSamples : JY9810.JY9810AITask
  • Trigger : JY9810.JY9810AITask
  • TriggerRouting : JY9810.AISync
  • Type : JY9810.AITrigger

- w -

  • WaitUntilDone() : JY9810.JY9810AITask
  • Window : JY9810.AIAnalogTrigger


9810 C# Programming Manual: Class Members - Functions

  • Add() : JY9810.AISignalExport
  • AddChannel() : JY9810.JY9810AITask
  • Clear() : JY9810.AISignalExport
  • ClearAll() : JY9810.AISignalExport
  • Commit() : JY9810.AISync
  • GetRecordPreviewData() : JY9810.JY9810AITask
  • GetRecordStatus() : JY9810.JY9810AITask
  • JY9810AITask() : JY9810.JY9810AITask
  • ReadData() : JY9810.JY9810AITask
  • ReadRawData() : JY9810.JY9810AITask
  • RemoveChannel() : JY9810.JY9810AITask
  • SendSoftwareTrigger() : JY9810.JY9810AITask
  • Start() : JY9810.JY9810AITask
  • Stop() : JY9810.JY9810AITask
  • WaitUntilDone() : JY9810.JY9810AITask


9810 C# Programming Manual: Class Members - Properties

- a -

  • Advanced : JY9810.AIRecord
  • Analog : JY9810.AITrigger
  • AvailableSamples : JY9810.JY9810AITask

- b -

  • BlockCount : JY9810.AIRecordAdvanced
  • BlockSize : JY9810.AIRecordAdvanced
  • BufLenInSamples : JY9810.JY9810AITask

- c -

  • ChannelID : JY9810.AIChannel
  • Channels : JY9810.JY9810AITask
  • Comparator : JY9810.AIAnalogTrigger
  • Condition : JY9810.AIAnalogWindowComparator
  • Coupling : JY9810.AIChannel

- d -

  • Device : JY9810.JY9810AITask
  • Digital : JY9810.AITrigger
  • DisableCalibration : JY9810.JY9810AITask

- e -

  • Edge : JY9810.AIAnalogTrigger , JY9810.AIDigitalTrigger
  • ExpectedRate : JY9810.AIExternalSampleClock
  • External : JY9810.AISampleClock

- f -

  • FileFormat : JY9810.AIRecord
  • FilePath : JY9810.AIRecord

- h -

  • Hysteresis : JY9810.AIAnalogTrigger

- i -

  • Impedance : JY9810.AIChannel

- l -

  • Length : JY9810.AIRecord

- m -

  • Mode : JY9810.AIRecord , JY9810.AITrigger , JY9810.JY9810AITask

- p -

  • PreTriggerSamples : JY9810.AITrigger
  • PreviewBufferSize : JY9810.AIRecordAdvanced
  • PulseRouting : JY9810.AISync

- r -

  • RangeHigh : JY9810.AIChannel
  • RangeLow : JY9810.AIChannel
  • Record : JY9810.JY9810AITask
  • ReTriggerCount : JY9810.AITrigger

- s -

  • SampleClock : JY9810.JY9810AITask
  • SampleRate : JY9810.JY9810AITask
  • SamplesToAcquire : JY9810.JY9810AITask
  • SamplesToPreviewBuffer : JY9810.AIRecordAdvanced
  • SignalExport : JY9810.JY9810AITask
  • Slope : JY9810.AIAnalogEdgeComparator , JY9810.AIAnalogHysteresisComparator
  • Source : JY9810.AIAnalogTrigger , JY9810.AIDigitalTrigger , JY9810.AISampleClock
  • Sync : JY9810.JY9810AITask
  • SyncDelaySamplesNum : JY9810.AISync

- t -

  • Terminal : JY9810.AIExternalSampleClock
  • Topology : JY9810.AISync
  • TransferedSamples : JY9810.JY9810AITask
  • Trigger : JY9810.JY9810AITask
  • TriggerRouting : JY9810.AISync
  • Type : JY9810.AITrigger

- w -

  • Window : JY9810.AIAnalogTrigger


9810 C# Programming Manual: Class Members - Variables

  • _adjustedSampleRate : JY9810.JY9810AITask
  • HighThreshold : JY9810.AIAnalogHysteresisComparator , JY9810.AIAnalogWindowComparator
  • LowThreshold : JY9810.AIAnalogHysteresisComparator , JY9810.AIAnalogWindowComparator
  • Threshold : JY9810.AIAnalogEdgeComparator


9810 C# Programming Manual: Main Page

9810 C# Programming Manual Documentation


9810 C# Programming Manual: JY9810 Namespace Reference

Classes | Enumerations
JY9810 Namespace Reference

Classes

class | JY9810AITask
JY9810 AI Task Class More...
class | AIChannel
AI Channel Parament Class More...
class | AISampleClock
Sample clock configuration class More...
class | AIExternalSampleClock
External Sample Clock Configuration Class More...
class | AITrigger
AI Trigger class More...
class | AIDigitalTrigger
AI Digital Trigger More...
class | AIAnalogTrigger
AI analog trigger . More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | AIRecord
AI Record class More...
class | AIRecordAdvanced
AI Record Advanced class More...
class | AISync
Configure sync signal More...
class | AISignalExport
AI Signal Export Class More...

Enumerations

enum class | AICoupling { DC = JY9810Import.JY9810_AI_DC_Couple , AC = JY9810Import.JY9810_AI_AC_Couple }
AI Coupling enum More...
enum class | AIImpedance { Impedance50Ohm = JY9810Import.JY9810_AI_OHM_50 , ImpedanceHigh = JY9810Import.JY9810_AI_OHM_1M }
AI Impedance More...
enum class | AITriggerType { Immediate = JY9810Import.JY9810_TriggerType_Immediately , Digital = JY9810Import.JY9810_TriggerType_Digital , Analog = JY9810Import.JY9810_TriggerType_Analog , Soft = JY9810Import.JY9810_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | AIDigitalTriggerEdge { Rising = 0 , Falling = 1 }
AI Digital Trigger Edge More...
enum class | AIMode { Finite = JY9810Import.JY9810_Finite , Continuous = JY9810Import.JY9810_Continuous , Record = 0x3 }
AIMode More...
enum class | AISampleClockSource { Internal = 0 , External = 1 }
AIClockSource Type More...
enum class | ClockTerminal { CLK_IN }
External Sample Clock Terminal More...
enum class | AITriggerMode { Start , Reference }
AI Trigger Mode More...
enum class AIDigitalTriggerSource {
PXI_Trig0 = JY9810Import.JY9810_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY9810Import.JY9810_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY9810Import.JY9810_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY9810Import.JY9810_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY9810Import.JY9810_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY9810Import.JY9810_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY9810Import.JY9810_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY9810Import.JY9810_DigitalTriggerSource_PXI_7 ,
PFI_0 = JY9810Import.JY9810_DigitalTriggerSource_TRIG_IN , PXIe_DStarB = JY9810Import.JY9810_DigitalTriggerSource_PXIe_DStarB , PXIe_DStarC = JY9810Import.JY9810_DigitalTriggerSource_PXIe_DStarC
}
AI Digital Trigger Source More...
enum class | AIAnalogTriggerSource { Channel_0 , Channel_1 , Channel_2 , Channel_3 }
AI Analog Trigger Source More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator More...
enum class AISignalExportSource {
PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 , PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 ,
PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 , PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 ,
StartTrig = JY9810Import.JY9810_StartTrigger , ReferenceTrig = JY9810Import.JY9810_RefTrigger , SyncTriggerOut = JY9810Import.SyncSignal_IN , SyncValidOut = JY9810Import.JY9810_PLL_SYNC_OUT ,
AIClkOut = 20 , PLLClkOut = 19 , AIClkDivider = 7 , SyncValidDelayOut = 25
}
AI Signal Export Source More...
enum class | FileFormat { Bin }
Streaming file format More...
enum class | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration More...
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 ,
PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 , PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 ,
PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 , PFI_0 = JY9810Import.JY9810_TriggerOut_TRG_OUT
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 ,
PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 , PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 ,
PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 , PFI_0 = JY9810Import.JY9810_TriggerOut_TRG_OUT
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...
enum class SignalExportDestination {
PXI_Trig0 = JY9810Import.JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import.JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import.JY9810_TriggerOut_PXI_2 , PXI_Trig3 = JY9810Import.JY9810_TriggerOut_PXI_3 ,
PXI_Trig4 = JY9810Import.JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import.JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import.JY9810_TriggerOut_PXI_6 , PXI_Trig7 = JY9810Import.JY9810_TriggerOut_PXI_7 ,
PFI_0 = JY9810Import.JY9810_TriggerOut_TRG_OUT
}
Output DestinationTerminal More...

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY9810.AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator

Enumerator
Edge | Edge Comparator
Hysteresis | Hysteresis Comparator
Window | Window Comparator

◆ AIAnalogTriggerEdge

enum JY9810.AIAnalogTriggerEdge
strong

AI Analog Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIAnalogTriggerSource

enum JY9810.AIAnalogTriggerSource
strong

AI Analog Trigger Source

Enumerator
Channel_0 | Channel_0
Channel_1 | Channel_1
Channel_2 | Channel_2
Channel_3 | Channel_3

◆ AIAnalogWindowCondition

enum JY9810.AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition

Enumerator
Entering | Rising
Leaving | Falling

◆ AICoupling

enum JY9810.AICoupling
strong

AI Coupling enum

Enumerator
DC | DC Coupling
AC | AC Coupling

◆ AIDigitalTriggerEdge

enum JY9810.AIDigitalTriggerEdge
strong

AI Digital Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIDigitalTriggerSource

enum JY9810.AIDigitalTriggerSource
strong

AI Digital Trigger Source

Enumerator
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
PFI_0 | Front Panel PFI_0
PXIe_DStarB | PXIe_DStarB
PXIe_DStarC | PXIe_DStarC

◆ AIImpedance

enum JY9810.AIImpedance
strong

AI Impedance

Enumerator
Impedance50Ohm | 50Ohm Impedance
ImpedanceHigh | 1MOhm High Impedance

◆ AIMode

enum JY9810.AIMode
strong

AIMode

Enumerator
Finite | Finite
Continuous | Continuous
Record | Record

◆ AISampleClockSource

enum JY9810.AISampleClockSource
strong

AIClockSource Type

Enumerator
Internal | Internal
External | External

◆ AISignalExportSource

enum JY9810.AISignalExportSource
strong

AI Signal Export Source

Enumerator
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7
StartTrig | AI_StartTrig
ReferenceTrig | AI_ReferenceTrig
SyncTriggerOut | PLL sync trigger out
SyncValidOut | PLL sync valid out
AIClkOut | PLL sync valid out
PLLClkOut | PLL sync valid out
AIClkDivider |
SyncValidDelayOut |

◆ AITriggerMode

enum JY9810.AITriggerMode
strong

AI Trigger Mode

Enumerator
Start | Start Trigger Mode
Reference | Reference Trigger Mode，Valid when JY9810AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JY9810.AITriggerType
strong

Trigger Type: Digital/Analog/Immediate

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Analog | Analog Trigger
Soft | Soft Trigger

◆ ClockTerminal

enum JY9810.ClockTerminal
strong

External Sample Clock Terminal

Enumerator
CLK_IN

Front Panel CLK_IN

◆ FileFormat

enum JY9810.FileFormat
strong

Streaming file format

Enumerator
Bin

Binary file format

◆ RecordMode

enum JY9810.RecordMode
strong

Two stream mode from enum Finite/Infinite

Enumerator
Finite | Finite Streaming
Infinite | InFinite Streaming

◆ SignalExportDestination

enum JY9810.SignalExportDestination
strong

Output DestinationTerminal

Enumerator
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7
PFI_0 | Front Panel PFI_0 Terminal

◆ SyncPulseRouting

enum JY9810.SyncPulseRouting
strong

Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port)

Enumerator
NONE | default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7
PFI_0 | Front Panel PFI_0 Terminal

◆ SyncTopology

enum JY9810.SyncTopology
strong

Synchronization board configuration

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum JY9810.SyncTriggerRouting
strong

Master card trigger signal routing (Master card routes trigger signal to this port)

Enumerator
NONE | default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7
PFI_0 | Front Panel TRG PFI_0


9810 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIAnalogTriggerComparator : JY9810
  • AIAnalogTriggerEdge : JY9810
  • AIAnalogTriggerSource : JY9810
  • AIAnalogWindowCondition : JY9810
  • AICoupling : JY9810
  • AIDigitalTriggerEdge : JY9810
  • AIDigitalTriggerSource : JY9810
  • AIImpedance : JY9810
  • AIMode : JY9810
  • AISampleClockSource : JY9810
  • AISignalExportSource : JY9810
  • AITriggerMode : JY9810
  • AITriggerType : JY9810
  • ClockTerminal : JY9810
  • FileFormat : JY9810
  • RecordMode : JY9810
  • SignalExportDestination : JY9810
  • SyncPulseRouting : JY9810
  • SyncTopology : JY9810
  • SyncTriggerRouting : JY9810


9810 C# Programming Manual: Package Functions

  • AIAnalogTriggerComparator : JY9810
  • AIAnalogTriggerEdge : JY9810
  • AIAnalogTriggerSource : JY9810
  • AIAnalogWindowCondition : JY9810
  • AICoupling : JY9810
  • AIDigitalTriggerEdge : JY9810
  • AIDigitalTriggerSource : JY9810
  • AIImpedance : JY9810
  • AIMode : JY9810
  • AISampleClockSource : JY9810
  • AISignalExportSource : JY9810
  • AITriggerMode : JY9810
  • AITriggerType : JY9810
  • ClockTerminal : JY9810
  • FileFormat : JY9810
  • RecordMode : JY9810
  • SignalExportDestination : JY9810
  • SyncPulseRouting : JY9810
  • SyncTopology : JY9810
  • SyncTriggerRouting : JY9810


9810 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY9810 |
C JY9810AITask | JY9810 AI Task Class
C AIChannel | AI Channel Parament Class
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI analog trigger
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIRecord | AI Record class
C AIRecordAdvanced | AI Record Advanced class
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class